Vyřešeno — vlákno je tím uzavřené a další odpovědi do něj nepřibývají.

Otázka

TK140308
TK140308 Zákazník Webhosting Vyřešeno

Chyba po změně hesla do DB

Dobrý den,

Nemohu se dostat na svůj web po změně hesla do DB.

Píše to hlášku:

Warning: session_start(): Failed to read session data: user (path: /data/web/virtuals/259570/virtual/session) in /data/web/virtuals/259570/virtual/www/libraries/joomla/session/handler/native.php on line 260
Error: Failed to start application: Failed to start the session

Používám CMS Joomla. Heslo jsem změnil na nové v souboru configuration.php.

V adresářové struktuře na FTP mám složku session, ale je prázdná.

0

5 odpovědí

JŠ255861
JŠ255861 Podpora

Dobrý den,

joomla má toto heslo nejspíše dočasně někde uložené. Váš problém jsem nasimuloval a všiml jsem si že se mi heslo v souboru configuration.php nastavilo zpět + se mi změnilo oprávnění souborů.

Řešením je tedy opravit práva souborů (v zákaznické administraci -> detail webhostingu -> levé menu -> nástroje -> Opravit práva souborů) a heslo nastavit v souboru znovu. Poté Vám web začne fungovat.

O uživateli: Roses are Red, Violets are Blue Unexpected '{' on line 32. Web: stackoverflow.com
0
ED133381
ED133381 Zákazník

Dobrý den, toto jsem zkoušel a stále stejná chybová hláška. Zkoušel jsem i změnit zpět PHP na verzi 5.6.

0
ED133381
ED133381 Zákazník

Abych ještě odpověděl, jedná se o migraci webu na WEDOS. Configuration.php je příslušně změněn

0
JŠ255861
JŠ255861 Podpora

Dobrý den,

změnil jste url webu nebo migrujete stále pod stejnou doménou? O jaký web se přesně jedná? Měl jste předtím HTTPS?

O uživateli: Roses are Red, Violets are Blue Unexpected '{' on line 32. Web: stackoverflow.com
0
TK140308
TK140308 Zákazník Přijatá odpověď

Dobrý den, za mě byl již problém vyřešen.

Problém byl nejspíše v tom, že pokud jsem si na FTP ve Filezilla clientovi otevřel soubor configuration.php a v něm změnil parametr public $password =  a uložil, tak se soubor nepřepsal. Musel jsem si configuration.php stáhnout k sobě, tam upravit parametr a nahrát zpět na FTP a přepsat.

0

Máte stejný problém?

Tohle vlákno je uzavřené a odpovídat už v něm nejde. Když vám odpověď nestačí nebo se vás týká něco jiného, položte vlastní dotaz — odkaz na tohle vlákno do něj klidně vložte.