Vyřešeno — vlákno je tím uzavřené a další odpovědi do něj nepřibývají.

Otázka

LT96547
LT96547 Zákazník Webhosting Vyřešeno

drupal 9 htaccess

Dobrý den

Měl bych dotaz na .htaccess pro Drupal 9. Stránku jsem vytvořil na localhost za pomoci composeru. Na webhosting jsem zkopíroval lokálně připravenou instanci Drupal, která se spouští z podsložky (www/web/index.php). Abych na webhostingu zaručil otevírání z www.mojedomena.com, vytvořil jsem v root složce www nový .htaccess s těmito proměnnými:

RewriteEngine on

RewriteCond %{HTTP_HOST} ^(www.)?276373.w73.wedos.ws$

RewriteCond %{REQUEST_URI} !^/web/

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*)$ /web/$1

RewriteCond %{HTTP_HOST} ^(www.)?276373.w73.wedos.ws$

RewriteRule ^(/)?$ web/index.php [L]

S tímto jsem dokázal otevřít doménu z www.mojedomen.com. Domovská stránka se načte

Tudíž do této části je to OK. Další problém nastal, když jsem z úvodní stránky otevíral nějakou stránku webu, nebo se chtěl nalogovat.

Po chvíli šrotování to vyhodilo chybu ‘The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.’

V adresním řádku se opakovalo:

‘/user/login?q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login&q=user/login’

Obdobný problém při jiných odkazech.

Zkusil jsem toto zacyklení spravit v setttings.php doplněním /web/ do řádku

$settings[‚config_sync_directory‘] = ‚/web/sites/default/files/config_

Částečně jsem se dostal dále teď stránky webu ohlašují chybu:

Internal Server Error

Pri zpracovani pozadavku doslo k vnitrni chybe. Pravdepodobne se jedna o chybu v .htaccess souboru.

Ctete instrukce v nasi znalostni bazi: Chyba 500 – Internal Server Error

Chci se zeptat:

  • Je nutné udělat nějakou změnu i v těch ostatních htaccess /web a sites/defaults?
  • Vytvářel jsem nový htaccess v root www ten, aspoň myslím spávně odkazuje na načítání webu z www/web. Ostatní htaccess pod web a sites/default jsou beze změny.

Děkuji za radu

0

1 odpověď

Máte stejný problém?

Tohle vlákno je uzavřené a odpovídat už v něm nejde. Když vám odpověď nestačí nebo se vás týká něco jiného, položte vlastní dotaz — odkaz na tohle vlákno do něj klidně vložte.