Fatal error na webu, který nejsem schopen odstranit

Vyřešeno80 zhlédnutíWebhosting
0

Dobrý večer,

na webu založeném na redakčním sys. WordPress jsem narazil na fatal error, který mi neumožňuje zobrazit web ani vstoupit do administrace ( /wp-admin). Instaloval jsem WooCommerce a je možné, že se jeho verze nemusela s nainstalovanou verzí wordpressu či nějakého pluginu.

Na webu v podstránce „/wp-admin“ svítí tento error:

Fatal error: Declaration of Automattic\WooCommerce\Container::get($id) must be compatible with Psr\Container\ContainerInterface::get(string $id) in /data/web/virtuals/248038/virtual/www/domains/tourdekosova.cz/wp-content/plugins/woocommerce/src/Container.php on line 32

Na webu došlo k závažné chybě. Pokyny naleznete v e-mailové schránce administrátora webu.

Další informace o řešení potíží s WordPressem.

V administrátorském emailu webu je mimo jiné tento text:

Požádejte poskytovatele hostingu o zjištění podrobností k tomuto problému.

WordPress verze 5.9
Aktuální šablona: Twenty Twenty (verze 1.0)
Aktuální plugin: WooCommerce (verze 6.1.1)
Verze PHP 7.1.33

Podrobnosti chyby
=================
Na řádku č. 32 v souboru /data/web/virtuals/248038/virtual/www/domains/tourdekosova.cz/wp-content/plugins/woocommerce/src/Container.php došlo k chybě typu E_COMPILE_ERROR. Chybová zpráva: Declaration of Automattic\WooCommerce\Container::get($id) must be compatible with Psr\Container\ContainerInterface::get(string $id)

Mohl by mi, prosím, někdo poradit?

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
MB313456 Vybral nejlepší odpověď 9. 1. 2023
0
TJ285257 34.31K - WEDOS Internet, a.s. 0 Comments

Dobrý den,
problém byl v nekompatibilitě nějakého pluginu s vaší nastavenou verzí PHP, tu jsem vám nastavil na 7.4 a web naběhl.

Role: Podpora
MB313456 Vybral nejlepší odpověď 9. 1. 2023
Prohlížíte 1 ze 1 odpovědí, klikněte zde pro zobrazení všech odpovědí.