Generování Let’s Encrypt SSL certifikátu z ISPConfig

Vyřešeno2.12K zhlédnutíVirtuální serveryISPConfig ssl VPS
0

Dobrý den.

Mám VPS SSD (vm27149) a k němu 4 domény a před pár dny mi vypršely SSL/HTTPS certifikáty, z nějakého důvodu přestalo fungovat automatické obnovování přes Let’s Encrypt (běželo to od roku 2019 bez potíží do teď).

Zkoušel jsem v ISPConfig u všech domén (v záložce Sites) odškrtnout a pak zase zaškrtnout checkboxy SSL a Let’s Encrypt SSL, tak si vybavuji že jsem původně certifikáty vytvářel, ale nyní se nic nestalo.

Jedna z domén je např. https://rocnicek.cz
a mám v aplikaci nastavený endpoint
https://rocnicek.cz/.well-known/acme-challenge/{token}
který vrací obsah souboru na VPS z
/usr/local/ispconfig/interface/acme/.well-known/acme-challenge/{token}

Vidím že endpoint funguje, vrací např. https://rocnicek.cz/.well-known/acme-challenge/pokus.txt

Koukám ale v té složce nejsou žádné další soubory (jen „empty.dir“). Jestli tomu dobře rozumím, tady by se mělo ukládat něco, co pak při tom ACMA challenge server musí vrátít pro ověření vlastnictví domény.

Prvně se chci zeptat vás, zda-li nevíte proč nefunguje vygenerování certifikátu přes váš ISPConfig tak jako dříve?

Díky za info a případný tip kam šáhnout.

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
PK265670 Vybral nejlepší odpověď 13. 8. 2021
0

Ok, takže problém byl ten, že na starém Debian 8 s ISPConfig je prehistorický certbot, který v podstatě ani nejde upgradovat.

Vyřešil jsem to přes ssh s pomocí https://github.com/acmesh-official/acme.sh

sh acme.sh –issue -d mojedomena.cz -w /usr/local/ispconfig/interface/acme

sh acme.sh –install-cert -d mojedomena.cz \
–cert-file      /var/www/clients/client0/mojedomena.cz/ssl/mojedomena.cz-le.crt  \
–key-file       /var/www/clients/client0/mojedomena.cz/ssl/mojedomena.cz-le.key  \
–fullchain-file /var/www/clients/client0/mojedomena.cz/ssl/mojedomena.cz-le.bundle \
–reloadcmd     „service apache2 force-reload“

Role: Zákazník
PK265670 Vybral nejlepší odpověď 13. 8. 2021
0
49.29K Odpověď od WEDOS Internet, a.s. 0 Comments

Dobrý den,

ISPConfig není v naší správě a neposkytujeme pro něj podporu. Taktéž Debian 8 je dnes již zastaralý a doporučujeme systém upgradovat/reinstalovat na novější verzi spolu s ISPConfig popř. certifikáty a další nastavení systému můžete spravovat přímo skrze konzoli.

Děkujeme za sdílení řešení problému.

Role: Podpora
PK265670 Odpověděl na otázku 13. 8. 2021