Konfigurace PHP a PHP libraries pro LowCost

Vyřešeno147 zhlédnutíWebhosting
0

Dobrý den,

mohl bych poprosit o pomoc s nastavením parametrů PHP serveru, popřípadě o kontrolu potřebných knihoven pro spuštění opencart.

Někde jsem se tu dočetl, že například parametr magic_quote_gpc se dá nastavit v webové administraci, nicméně jsem je tam nenašel.

Do jaké míry se dá k těmto účelům použít .htaccess?

I will need to have the following PHP libraries installed in your PHP configuration:

  • PHP 8.0 or later
  • Curl
  • GD Library
  • Iconv
  • Mbstring
  • OpenSSL Encrypt
  • ZipArchive
  • Zlib

Additionally, I want to turn on the following PHP settings:

  • file_uploads NEED TO BE
  • magic_quotes_gpc  NEED TO BE
  • register_globals – set up by default
  • session_auto_start – already set up

Dekuji a jsem s pozdravem,

MO

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
MB313456 Vybral nejlepší odpověď 1. 2. 2024
0
95.25K Odpověď od WEDOS Internet, a.s. 0 Comments

Dobrý den,

vp phpinfo pro PHP 8.0 hodnotu magic_quotes_gpc nevidím. Podle PHP manuálu je nejvýš v PHP 7, což je v rozporu s Vaším požadavkem na PHP 8 a vyšší.

Problém open_basedir řešte změnou nastavení z adresáře „/“ na adresář odpovídající tomu v chybové hlášce, případně proveďte úpravu podle návodu na řešení problému open_basedir omezení u Vašeho software.

Role: Podpora Web: https://kb.wedos.com Vizitka: WEDOS Specialista na Znalostní bázi
MB313456 Odpověděl na otázku 17. 1. 2024
Prohlížíte 1 ze 5 odpovědí, klikněte zde pro zobrazení všech odpovědí.