Přechod na vyšší PHP s WordPressem

Vyřešeno149 zhlédnutíWebhostingphp 7.0 wordpress update
0

Dobrý den,

mám na hostingu starou verzi PHP 5.4 a běžící WordPress. Potřebuji aktualizovat WordPress na nejnovější verzi, ale je nutný PHP 7 a vyšší. Když provedu změnu, přestane mi fungovat web. Jak prosím bezpečně převést hosting na vyšší PHP tak, aby wordpress dál fungoval? Návod se mi zde nepodařilo najít 🙁

Předem děkuji za rady!

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
MB313456 Vybral nejlepší odpověď 25. 11. 2023
0
95.78K Odpověď od WEDOS Internet, a.s. 0 Comments

Dobrý den,

změna z PHP 5.4 na 7.4 nebo dokonce 8.0+ je hodně velký skok.

Zkuste použít tento externí článek podporovaných verzí PHP v různých verzích WordPressu a aktualizovat postupně. Začal bych navýšením na PHP 5.6, které má support až do WordPress 6.1, a odtud jít na PHP 8.1 a další upgrade.

Kompatibilita pluginů a šablon je samostatná, pokud můžete, minimálně pluginy bych před upgradem doporučil povypínat, u šablony si ověřte kompatibilitu a zařiďte se podle toho, nejspíš podobně jako s jádrem WordPressu.

Role: Podpora Web: https://kb.wedos.com Vizitka: WEDOS Specialista na Znalostní bázi
MB313456 Vybral nejlepší odpověď 25. 11. 2023
Prohlížíte 1 ze 1 odpovědí, klikněte zde pro zobrazení všech odpovědí.