Rozdilne verze PHP na stejnem webhostingu

Vyřešeno772 zhlédnutíWebhosting
0

Na stejnem webhostingu mam webovou aplikaci (v Laravel) bezici na PHP verzi 5.6.40, ktera vyuziva MySQL databazi (na WEDOSu, patri k webhostingu). Potrebuji rozbehat – na stejnem webhostingu – dalsi aplikaci (take Laravel), ktera je ale vyvijena na PHP verze 7. Tato druha web aplikace vyuziva take stejnou MySQL databazi (je to API rozhrani).

Aplikace c.1 (standartni webovka) je ve foldru: 0:/www/subdom/social/  – a normalne (spravne) funguje na URL: https://social.bigoo.eu/public/index.php

Aplikaci c.2 (API rozhrani) jsem dal do samostatniho foldru: 0:/www/subdom/API/  – ale URL: http://bigoo.eu/subdom/API/public/index.php vraci chybovou hlasku: „Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version „>= 7.3.0“. You are running 5.6.40. in /data/web/virtuals/107149/virtual/www/subdom/API/vendor/composer/platform_check.php on line 25″

Jak nastavit rozdilnou verzi PHP pro tuto Laravel aplikaci (na stejnem webhostingu)? Nebo – kdyz to nejde – jak sprovoznit aplikaci c.2 na jinem WEDOS webhostingu, ale tak aby mohla pracovat s MySQL databazi patrici k memu puvodnimu webhostingu (insert/update/delete/select)?

dekuji

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
JŠ255861 Vybral nejlepší odpověď 27. 9. 2021
0
44.22K Odpověď od WEDOS Internet, a.s. 1 Komentář

Dobrý den,

Soubory lze spouštět s různými verzemi PHP, nicméně je zde nutnost soubory dle konkrétní verze přejmenovat, což nemusí být vždy ideální řešení pokud se jedná o robustní/cizí kód. Případně je pak i možné objednat pro subdoménu vlastní webhosting, kde si požadovanou verzi PHP nastavíte.

https://kb.wedos.com/cs/webhosting/nastaveni/webhosting-konfigurace-php/

Role: Podpora
DL70539 publikoval nový komentář 24. 6. 2021
Prohlížíte 1 ze 2 odpovědí, klikněte zde pro zobrazení všech odpovědí.