upgrade php installation to higher version

Vyřešeno500 zhlédnutíWebSite
0

Dobrý den,

na stránkách se mi objevilo toto upozornění: Warning: json_encode() expects parameter 2 to be long, string given in /data/web/virtuals/48642/virtual/www/wp-content/plugins/foogallery/includes/functions.php on line 1580

PHP compatibility checker mi píše toto upozornění: : Please be advised that for the most reliable PHPCompatibility results, PHP 5.4 or higher should be used. Support for lower versions will be dropped in the foreseeable future. You are currently using PHP 5.3.29. Please upgrade your PHP installation to version 5.4 or higher.

Na fórech jsem se dočetl, že mám požádat přímo Vás.

Děkuju za instalaci nebo za návod, jak postupovat.

MK

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
MB313456 Vybral nejlepší odpověď 1. 10. 2022
0
90.95K Odpověď od WEDOS Internet, a.s. 0 Comments

Dobrý den,

konfiguraci PHP na webhostingu změníte podle tohoto návodu. Ve Vašem případě několik poznámek:

  • Nejnižší verze PHP, kterou na webhostingu nyní můžete nastavit, je 5.4. K předchozí verzi 5.3 se tedy po změně už nemůžete vrátit.
  • Verze PHP 7.3 a nižší jsou zastaralé a mohou obsahovat bezpečnostní díry. Jejich používání tedy nedoporučujeme, ale
  • velké změny PHP (např. extrémně z 5.3 na 8.1) mohou způsobit nefunkčnost webu. Návod na práci s takovými chybami najdete v návodu WordPress – Nefunkční web.
Role: Podpora Web: https://kb.wedos.com Vizitka: WEDOS Specialista na Znalostní bázi
MB313456 Vybral nejlepší odpověď 1. 10. 2022
Prohlížíte 1 ze 4 odpovědí, klikněte zde pro zobrazení všech odpovědí.