Vyřešeno — vlákno je tím uzavřené a další odpovědi do něj nepřibývají.

Otázka

Mh270181
Mh270181 Zákazník Virtuální servery Vyřešeno

Vzdálené připojení k db

Dobrý den, používám vaše vps kde mám databázi potřebnou k webu, avšak web mám na webhostingu kde mi to vypíše chybu refused to connect. Což znamená že asi musim na vps povolit vzdálené připojení ale bohužel to neumim. Debian 9

0

4 odpovědí

KB218908
KB218908 Podpora

Dobrý den,

z webhostingu se můžete připojit na databázi VPS,

z VPS se nemůžete připojit na databází webhostingu.

Pokud máte problém v prvním případě, je potřeba zkontrolovat správné přihlašovací údaje a porty, dále si zkontrolovat, jestli máte v iptables (pokud máte ošetřeno) otevřené porty k databázi.

O uživateli: Programátor | Získali jsme akreditaci ICANN ... Web: blog.wedos.cz
0
MZ61249
MZ61249 Zákazník Přijatá odpověď

Zkontroloval bych nastavení databáze (mysql, mariadb), zda v konfiguraci je něco podobného:

[apcode language=“php“]

# skip_networking
bind-address = 0.0.0.0

[/apcode]

A pak samozřejmě zkontrolovat firewall, pokud tam nějaký běží, jestli nebrání spojení. Výchozí port je TCP/3306.

O uživateli: Zákazníkem od roku 2011... :-) Web: socl.cz
0

Máte stejný problém?

Tohle vlákno je uzavřené a odpovídat už v něm nejde. Když vám odpověď nestačí nebo se vás týká něco jiného, položte vlastní dotaz — odkaz na tohle vlákno do něj klidně vložte.