Woocomerce PHP 8.0+ – Call to undefined function putenv()

Vyřešeno1.20K zhlédnutíWebhostingphp 8.0 php wordpress putenv
0

Zdravím,

Pochopil jsem, že chyba Uncaught Error: Call to undefined function putenv() znamená, že na hostingu není povolená funkce putenv.

Plánuje se tuto funkci povolit, případně je nějaké řešení, jak provozovat WordPress s Woocomerce na hostingu s PHP 8.0+?

Role: Zákazník
Otázka je uzamčena pro nové odpovědi.
MB313456 Vybral nejlepší odpověď 25. 10. 2022
0
95.13K Odpověď od WEDOS Internet, a.s. 0 Comments

Dobrý den,

funkce putenv() je zakázaná i v jiných verzích PHP. Řešením může být z chybové hlášky zjistit, kde skript tuto funkci volá, a zakomentovat ji.

Další možná řešení, která jsem našel:

Role: Podpora Web: https://kb.wedos.com Vizitka: WEDOS Specialista na Znalostní bázi
MB313456 Vybral nejlepší odpověď 25. 10. 2022
Prohlížíte 1 ze 1 odpovědí, klikněte zde pro zobrazení všech odpovědí.